Xyphien Forums

Hello Guest!. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, sell your games, upload content, as well as connect with other members through your own private inbox!

MV Mac Glitch? "Cannot read (so-and-so).json file"

Ashlehhh

Villager
Xy$
0.00
I'm desperate. I've worked weeks on a project that I left open overnight, and when I returned to it, none of the files were readable. I've searched through the internet and I've tried everything. I've only managed to salvage the overworld map.

Based off the knowledge I have, the mapsinfo.json file tells the program how many maps there are and what is on the maps. Is there any possible way I can save at least the mapsinfo.json file?
 

Attachments

LTN Games

Master Mind
Resource Team
Xy$
0.01
Unfortunately, if it's unreadable you may be out of luck. It's very important to make backups of your projects every day or so just so things like this don't happen.
As an alternative, if it's on the MapInfos.json you may be able to create your own but it will require a bit of work and understanding of the JSON syntax.

This snippet below is pulled from my MapInfos.json and it's basically just simple info about the current state of the map. The file will have every map you have in this file and each with its own information.

Code:
{"id":1,"expanded":true,"name":"World","order":2,"parentId":0,"scrollX":1564,"scrollY":1021},
So if you're willing to give it a try, open your MapInfos.json (or create a new one) in a text editor preferably one for editing a programming language, like Visual Studio code or Notepad++.

It may be hard to explain to a non-programmer but you would copy the above snippet multiple times, one for each map you have and then change the id and order number to a different number, just make sure it's in order, so 1, 2, 3, 4 etc.

A few things to remember when editing the file, if it's a new file from a new project (which is what I would recommend) then if you open it, it will look like this.
Screenshot_2.png
In any case, you could follow the same style, just copy the first line and paste it after the first line and continue for as many maps as you previously had.

Remember the last line does not have a comma , at the end. So your last map entry be sure to omit the comma. If using VS Code it will give you a small red squiggly line at the end of the file to warn you about this.

You probably won't have to worry about the name of the maps because you can re-edit the names inside RMMV's editor as well organize the order of them etc.

P.S I did a quick edit of mine for you, copy this entire thing and replace what is inside your MapInfos.json (be sure to backup what you have first)

Code:
[
null,
{"id":1,"expanded":false,"name":"Unnamed","order":1,"parentId":0,"scrollX":0,"scrollY":0},
{"id":2,"expanded":false,"name":"Unnamed","order":2,"parentId":0,"scrollX":0,"scrollY":0},
{"id":3,"expanded":false,"name":"Unnamed","order":3,"parentId":0,"scrollX":0,"scrollY":0},
{"id":4,"expanded":false,"name":"Unnamed","order":4,"parentId":0,"scrollX":0,"scrollY":0},
{"id":5,"expanded":false,"name":"Unnamed","order":5,"parentId":0,"scrollX":0,"scrollY":0},
{"id":6,"expanded":false,"name":"Unnamed","order":6,"parentId":0,"scrollX":0,"scrollY":0},
{"id":7,"expanded":false,"name":"Unnamed","order":7,"parentId":0,"scrollX":0,"scrollY":0},
{"id":8,"expanded":false,"name":"Unnamed","order":8,"parentId":0,"scrollX":0,"scrollY":0},
{"id":9,"expanded":false,"name":"Unnamed","order":9,"parentId":0,"scrollX":0,"scrollY":0},
{"id":10,"expanded":false,"name":"Unnamed","order":10,"parentId":0,"scrollX":0,"scrollY":0},
{"id":11,"expanded":false,"name":"Unnamed","order":11,"parentId":0,"scrollX":0,"scrollY":0},
{"id":12,"expanded":false,"name":"Unnamed","order":12,"parentId":0,"scrollX":0,"scrollY":0},
{"id":13,"expanded":false,"name":"Unnamed","order":13,"parentId":0,"scrollX":0,"scrollY":0},
{"id":14,"expanded":false,"name":"Unnamed","order":14,"parentId":0,"scrollX":0,"scrollY":0},
{"id":15,"expanded":false,"name":"Unnamed","order":15,"parentId":0,"scrollX":0,"scrollY":0},
{"id":16,"expanded":false,"name":"Unnamed","order":16,"parentId":0,"scrollX":0,"scrollY":0},
{"id":17,"expanded":false,"name":"Unnamed","order":17,"parentId":0,"scrollX":0,"scrollY":0},
{"id":18,"expanded":false,"name":"Unnamed","order":18,"parentId":0,"scrollX":0,"scrollY":0},
{"id":19,"expanded":false,"name":"Unnamed","order":19,"parentId":0,"scrollX":0,"scrollY":0},
{"id":20,"expanded":false,"name":"Unnamed","order":20,"parentId":0,"scrollX":0,"scrollY":0}
]
Once complete open RMMV and it should show a list of maps with the title "Unnamed" in your map list (if the map with the corresponding id is available). I hope this helps in some way, I know it's not the best explanation and it may not even work because of the MapInfos.json my not be the only corrupted file. If you have more questions don't be afraid to ask.
 

Jodis

Adventurer
Xy$
0.00
I have window 10 and this is going on with me too. For some reason the folder keeps resetting to read only. I don't know why or how to fix it.

Did some looking. All i can find out is that the file is corrupt. I didn't open it at all. So what i am going to do is zip up the data and js folder after i edit the game. This way i can restore it.
[doublepost=1483520825,1483492422][/doublepost]Think i found out why it happened. Let me see you have steam ver. Just like me. clicked on Game.rpgproject file and ran the game but it didn't start why because we both didn't have steam running. Talked with hubby a programmer and he said very possible that this may be the cause of it do to not loading up properly.
 
Top