Xyphien Forums

Hello Guest!. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, sell your games, upload content, as well as connect with other members through your own private inbox!

"Type Error: Undefined is not a function"

PsychoFox

Villager
Xy$
0.00
So, I was trying to port a test RPG to android APK. Though after following the instructions I keep getting the "Type error" The game works fine on pc, but after it gets converted it doesn't work... I've tried two different times (with different projects) And nothing seems to work.
I have everything installed as far as I can tell
And if it's any help I watched this video along side the official instructions

The only thing I can possible think of is it being my android studio tools (They have numbers after, but I assumed that was only because they were slightly newer.)

Any help would be greatly appreciated!
Here's my CMD output (If that'll help)

Checking manifest file Checking system requirements...ok
Starting application build (x86)
*Checking keystore for signing No keystore provided for signing. Using xwalk's keystore for debugging. Please use a valid keystore when distributing to the app market.
* Updating project with xwalk_core_library
* Checking for external extensions
* Copying native libraries for x86
* Building Android apk package with Crosswalk embedded (x86)
[javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
[javac] 3 warnings
[javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
[javac] 3 warnings BUILD SUCCESSFUL Total time: 35 seconds (Location: C:\Users\PopFo\Desktop\Learning MV\www\Sample_0.0.1_x86.apk)
Starting application build (arm)
* Checking keystore for signing No keystore provided for signing. Using xwalk's keystore for debugging. Please use a valid keystore when distributing to the app market.
* Updating project with xwalk_core_library
* Checking for external extensions
* Copying native libraries for arm
* Building Android apk package with Crosswalk embedded (arm)
[javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
[javac] 3 warnings
[javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
[javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
[javac] 3 warnings BUILD SUCCESSFUL Total time: 19 seconds (Location: C:\Users\PopFo\Desktop\Learning MV\www\Sample_0.0.1_arm.apk)
 

LTN Games

Master Mind
Resource Team
Xy$
0.01
I've been reading around the community that the latest MV 1.5 and it's Pixi 4.4.1 is causing problems with all Android ports. I never looked into the problem much but it seems Pixi is causing the games to crash on boot.
 

PsychoFox

Villager
Xy$
0.00
I've been reading around the community that the latest MV 1.5 and it's Pixi 4.4.1 is causing problems with all Android ports. I never looked into the problem much but it seems Pixi is causing the games to crash on boot.
Are there any work arounds to it? Or is it something that's being worked on?
 
Top